Yourlabs

django-autocomplete-light 2.3.3 release

| by jpic | python django django-autocomplete-light

This release fixes an important usability but on the manychoice fields, and introduces a minor backward compatibility break:

  • #563 Don’t disable multiplechoicewidgets if select is [multiple], bd9ca0085
  • Don’t import anything in init anymore if on django 1.9
  • test_project fixes, for the above.

Disabled field bug

Thanks George Tantiras for reporting the bug ! Note that only paliative solutions have been taken for v2:

As for v3, it is designed to support any number of autocomplete scripts, and the first proposed implementation is with select2, so chances that this kind of bug happen are greatly reduced.

BC break

If you haven’t already, replace your import autocomplete_light statements by from autocomplete_light import shortcuts as autocomplete_light. This is required if using django 1.9+.

Hopefuly for your little fingers, that long statement becomes from dal import autocomplete in v3.